1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-60 problems

Discussion in 'Meyer / Diamond Products Discussion' started by plow tech, Feb 7, 2011.

  1. plow tech

    plow tech Member
    Messages: 32

    had a problem with the o ring under cyilinder replaced worked good for two storms then started to drop again then would not go up pump runs and tries to go up but will not,rebuilt pump again and lasted a storm now it is doing the same thing again,started leaking down at first now will not go up any ideas on what would cause this thing to keep leaking by the lower o ring?i have rebuilt many meyers pumps never had one do this.
  2. Bashby

    Bashby Senior Member
    Messages: 228

    The A valve may be sticking
  3. dlcs

    dlcs 2000 Club Member
    Messages: 2,142

    I had the same problem with a E-60. Chnaged the a-valve and the ball and spring below it, problem solved, thanks to B&B.:drinkup:
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    is the packing cup good? it is bolted to the bottom of the cylinder rod.
  5. cmo18

    cmo18 Senior Member
    Messages: 814

    Rust inside the cylinder ripping your seal. Same thing happened to mine

    I honed the cylinder the 2nd time
  6. NickT

    NickT Senior Member
    Messages: 707

    I had the same problem some years ago, replace lift ram if it has rust on it and replace the washer seal that it goes into. As far as it not going up maybe some ice is in the reservoire.other than that the o rings and a valve should be checked:gunsfiring::gunsfiring::gunsfiring:
    good luck
  7. lowestnowplowin

    lowestnowplowin Junior Member
    Messages: 9

    Like to know what was wrong.