1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-60 problems again !!!!!!!!

Discussion in 'Truck & Equipment Repair' started by leaner, Dec 27, 2009.

  1. leaner

    leaner Junior Member
    Messages: 7

    I seem to be having trouble still with the plow lifting, sometimes it will rise right up while other times I have to hold the up switch for what seems like a long time, also it sometimes will slowly go down on it`s own, I have replaced the motor, the A valve and have changed the battery in my truck, it is almost like there is a bad valve or seal somewhere in the pump, any ideas folks, thanks
     
  2. poncho62

    poncho62 Senior Member
    Messages: 431

    Trouble going up.....Usually, that spells "B" valve, Leaking down would be "A"valve, but its new. I am thinking a bad seal in your lift cylinder....bottom cup seal. That could cause both.
     
  3. Plowfixguys

    Plowfixguys Senior Member
    Messages: 222

    Is your power unit clean inside? You could have some dirt or "junk" floating around clogging things up that might stick the valve now and then.
     
  4. leaner

    leaner Junior Member
    Messages: 7

    do i have to take the whole unit apart to clean it ????
     
  5. Plowfixguys

    Plowfixguys Senior Member
    Messages: 222

    That would be the best thing to do. Its difficult to get it really clean unless you disassemble it all the way. Also make sure you blow out all the passageways with air and also the valves.