1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-60 angling problem

Discussion in 'Meyer / Diamond Products Discussion' started by jlb2500hd, Jan 15, 2007.

  1. jlb2500hd

    jlb2500hd Member
    from N.Y
    Messages: 38

    I have a 5 year old E-60 pump with MDII mount, the problem i have is when i try to angle the plow right, it goes left and vice versa, the other thing is that when it angles either way, in order for it to angle back i have to fully angle the plow all the way in order for it to go back the other way, I can't stop in mid angle and go the other way, any help would be greatly appreciated to this frustrating problem.
  2. Whip

    Whip Member
    Messages: 87

    Your hoses/connections are opposite what they should be on the valve block. Just swap the couplers there. Try that first and see if the other "problem" is eliminated. I had never heard that one before.
  3. jlb2500hd

    jlb2500hd Member
    from N.Y
    Messages: 38

    I don't think it is the hoses, because it was working fine before, it is definetly a weird problem, i'm almost thinking it might be something in the truck to plow connector or possibly the C solenoid, but i'm not sure
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,990

    maybe the controller?
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Could be a couple things.Check you plow connector first. MDII's are famous for electrical gremlin's due to the connector plug. Also a defective "C" coil/valve.Do you have a touch pad style controller? If so it could be in the controller too like basher said.