1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-60 and Slik Stik

Discussion in 'Meyer / Diamond Products Discussion' started by Earl W., Dec 21, 2013.

  1. Earl W.

    Earl W. Member
    Messages: 68


    Have a E-60 and Slik Stick

    Plow quit going to right, would go left little by little but wouldn't come back right. Raises fine

    Cleaned connections no change

    had c coil so replaced coil and stem no change

    found no power to red wire from harness near slik stick and of course to c coil

    Have power to green wire in harness

    I eventually found if I wiggled the switch hard to right plow would jerk and most times go right but still no power on red wire at harness


    Cant understand why no power at harness but wiggling the slik stick hard right allows plow to go right

    It seems that the slik stick is bad and not transferring power correctly and probably needs replaced.

    Does this seem correct?

    Is there any other trouble shooting to do to confirm that the slik stick is bad?

  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,156

    Red wire should be up, B coil/valve. Green wire is right, C coil/valve. Yes when the slick stik starts to wear out you can sometimes get it to work by pressing harder and wiggling it around. Replace the slick stik.
    Last edited: Dec 21, 2013
  3. Earl W.

    Earl W. Member
    Messages: 68

    thanks Kimber. The slik stik was bad.