1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-47 won't raise

Discussion in 'Meyer / Diamond Products Discussion' started by machinekiller, Mar 9, 2008.

  1. machinekiller

    machinekiller Junior Member
    Messages: 12

    Hi all,
    New to forum and snow plow ownership. Bought a second hand E-47 for my 99 Dodge Ram 1500. Worked great the first storm. I've got an unpaved driveway that's about 1500 feet long. Now the motor runs, but the pump does nothing, won't raise the blade. Can't tell if the blade would move side to side because I can't get it off the ground. I topped off the fluid. Still nothing. Anybody got any ideas on where I should be looking for the problem. Any help is much appreciated.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Generally if the motor runs but it wont lift it's usually due to either the "A" valve stuck open or the "B" valve not opening for one reason or another. Occasionally they'll wipe out the packing cup seal on the lift ram.

    Here's the manual: Pump manual

    It's for the E57 but the 47 and 57 are the same except for the gear pump and motor. The diagnosis and component terminology is all the same.

    FYI: It should still angle even on the ground, provided it's not stuck in a snow bank of course.
     
  3. machinekiller

    machinekiller Junior Member
    Messages: 12

    Thanks for the maual. That should givve me the information I need. Now all I need is the time to get to it.
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Sorry, can't help ya with that one.. :)


    But good luck in your diagnosis, and your welcome. :waving: