1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-47 Raises without plow but not with plow on

Discussion in 'Meyer / Diamond Products Discussion' started by robslawncare, Dec 9, 2010.

  1. robslawncare

    robslawncare Junior Member
    Messages: 11

    I had my e47 rebuilt last season and worked good when I took it off in spring. I just hooked it up tonight expecting everything to be ok and it wont raise the blade. I checked fluid and added a little bit more but still wont raise. I believe coils and valves were replaced as well last season. The pump will raise without the plow on but still sounds weak. Any ideas what to check? I leave the pump and frame on truck all summer as well. It is on a 95 K2500. Thanks
     
  2. Nasty-Z

    Nasty-Z Senior Member
    Messages: 370

    First guess would be a failing pump unit , only real way to diagnose that would be to check output pressure . Does it angle O.K ? If it does I would suspect low pump pressure .

    Could also be the seal at the base of the lift ram has gone south on you . Can you "help" it lift by following the blade up with your hands while someone operates the control, and if it will lift like this will it stay up ?

    TOM
     
  3. robslawncare

    robslawncare Junior Member
    Messages: 11

    I am goin to have someone help me lift the plow while I hit control and see what it does. It wont angle as well as lift.
     
  4. robslawncare

    robslawncare Junior Member
    Messages: 11

    Went to fire it up today and it wouldnt even lift without the plow now. I looked at the ground hooked up on the motor cap and went to wiggle wire and it broke right off from rust. I am going to grab a new cap and hook it back up. I am positive that the cap wasnt replaced when I got it rebuilt. Would the bad ground make the pump sound weak like that?
     
  5. geer hed

    geer hed Senior Member
    Messages: 275

    Yep it can. A bad ground can cause all kinds of problems.
     
  6. thandrinos

    thandrinos Member
    Messages: 67

    Had similar problem with E60. With a lot of load on the electrical system when plowing at night plow wouldnt go up with out some RPM. Replace all cables from alternator to fuse box to battery to plow and plow pump ground wire..plow has never came up as fast as it does now.