1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-47 Pump

Discussion in 'Meyer / Diamond Products Discussion' started by ToddM NJ, Feb 26, 2012.

  1. ToddM NJ

    ToddM NJ Member
    Messages: 45

    Hey guys. This weekend I took my plow off the truck. The problem I am having is reconnecting the hose back into the pump. I do have the quick connects but it seems the pressure is built up to hard to connect it. Is there anyway to release the pressure? Thanks!
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Double up a shop towel over the male connector you're having the problem with and give it a square tap on the end with a small hammer. This will "pop" the pin/ball allowing the pressure buildup (and a little fluid, hence the shop towel) to escape thus allowing the pin/ball to move freely when you connect it.
     
  3. ToddM NJ

    ToddM NJ Member
    Messages: 45

    Thanks so much! Everything back together now!!!!
     
  4. JeepCoMJ

    JeepCoMJ Senior Member
    Messages: 284

    next time, don't disconnect the plow from the pump with the blade turned full lock.


    if it happened because of a failed coil or valve, it's understandable. otherwise...just make sure you don't have anything pushed as far as it will go.
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    I like to use a block of wood to keep from possibly scarring the coupler.