1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

e-47 lift problems

Discussion in 'Meyer / Diamond Products Discussion' started by EaTmYtAiLpIpEs, Aug 31, 2009.

  1. EaTmYtAiLpIpEs

    EaTmYtAiLpIpEs 2000 Club Member
    Messages: 2,607

    I just bought a 1995 Ford F-350. it has a meyers e-47 plow on it. Everytime I go to raise it, it clicks when you hit the lever to go either up, left, right. But today it worked for about 30 secs and then it stopped working. I think the motor is bad on the pump. When I tested for power I get power at the plug and at the motor itself. So I ruled out the solenoid and the only thing left is the motor. Let me know what you think.
     
  2. noble@esitrucks

    noble@esitrucks Member
    from 20181
    Messages: 92

    use a battery jumper pack and put one on the pos. side and one on the ground for the pump. if it doesn't work then you are about as close to 100% bad as you can get.
     
  3. plowinginma

    plowinginma Senior Member
    from MA
    Messages: 326

    motors very rarely work sometimes and then not.. Unless of course they are drawing to much amps and something else is cutting out.. A solenoid will show volatage if it is bad but will not allow the amps.. The most common problem with most electric plows... is the solenoid.. not to say you don't have a bad motor.. just need to be a little more sure before you spend the$$..
     
  4. noble@esitrucks

    noble@esitrucks Member
    from 20181
    Messages: 92

    I agree with plowinginma. not to say that you don't have a bad motor, but motor relay solenoids go bad more frequently than motors. Grounds are also big problems. The jumper pack will cancel both the solenoid and the ground issue; unless there is alot of rust between the motor and the sump base.
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Check the solenoid before replacing the motor, as was posted they will pass voltage but not enough amps. The same effect occurs from heavy corrosion in the power and ground cables.
     
  6. EaTmYtAiLpIpEs

    EaTmYtAiLpIpEs 2000 Club Member
    Messages: 2,607

    i ordered the solenoid. it is comming in tomarrow morning. I put my jump starter on it again and this time the motor turned andd worked so I ruled it as the solenoid.
     
  7. noble@esitrucks

    noble@esitrucks Member
    from 20181
    Messages: 92

    Awesome. I hope everything works out.
     
  8. Nascar24

    Nascar24 Senior Member
    Messages: 645

    Hi

    With the low cost of a solenoid even if nothing changes it's an inexpensive back up part.

    I ran into a couple of strange issue just last week, installed a refirb plow, all new harnesses and reman pump, no left running light, checked everything, found no power coming out of main harness for running lights on one side, found a defective plug, pin was missing the last 1/8", no contact. The other issue was, the plow worked fine upon install, next morning I had lift, no angle, check all the connections, all good, no magnetism at the c- coil, which was new along with the c-valve, called the rebuilder, found that coil had bad connect at the top of stud. removed the coil, cleaned the new paint and bottom of the coil, worked fine. Never fails, 95% of the time it comes back to connections, and its always the ones we assume are fine, lol.

    I hope you find your gremlin, they will drive you nuts, till you find the cause.

    Good luck
     
  9. EaTmYtAiLpIpEs

    EaTmYtAiLpIpEs 2000 Club Member
    Messages: 2,607


    haha thanks man. i know it is always connections. I had connection issues with my fisher last year. if it drives me nuts I will sell the meyers setup and buy a fisher for it lol
     
  10. EaTmYtAiLpIpEs

    EaTmYtAiLpIpEs 2000 Club Member
    Messages: 2,607

    alright solenoid was shot. I put the new one in and it goes up, down, left right haha. thanks for all the help guys very appreciated