1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

e-46 motor continously running?

Discussion in 'Meyer / Diamond Products Discussion' started by windrowsnow, Dec 22, 2008.

  1. windrowsnow

    windrowsnow Senior Member
    from nw ohio
    Messages: 168

    motor on pump continues to run even though switches are disconnected.....plow goes up and stays angled to the left once angled right it shoots back to the left....have to disconnect the power from the battery....disconnected switches and motor still runs....need help.
     
  2. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    bad solenoid
     
  3. sefh

    sefh Senior Member
    Messages: 437

    It sounds like your solinoid is stuck and supplying your motor with cont. power. I would replace it and see if it helps. Where are you located at. I see it says NW Ohio. I don't live that far from there. If you can't figure it out PM and I will come help you out.
     
  4. windrowsnow

    windrowsnow Senior Member
    from nw ohio
    Messages: 168

    good stuff i figured it would be simple solenoids are simple...hell i had a bad ground on it two seasons ago and every bump i hit would kill the solenoid. thanks guys appreciate it.
     
  5. windrowsnow

    windrowsnow Senior Member
    from nw ohio
    Messages: 168

    yup was the solenoids thanks guys appreciate...cheapest fix yet