1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Drivers side Plow Low Beam wont turn on

Discussion in 'Fisher Engineering Discussion' started by lcncapo, Dec 22, 2012.

  1. lcncapo

    lcncapo Junior Member
    from roch ny
    Messages: 16

    Hey guys, i have a wiring issue.

    My plow is a minute mount with inst-act pump and 2 plug setup with 2 relays.

    At first I only had parking lights, no headlamps in high or low beam.

    i replaced the relays and now i have high beams on both but for low beams i only have the passenger side working.

    Went to autozone, got a replacement Drivers side light ( 2E Sealed beams) and it still isnt working.
    FYI i am unsure as to whether i had high beams prior to the bulb replacement.

    Can anyone help me figure this out. parking and turns work fine, just no low beam drivers side. Vehicle lighting works fine with plow disconnected.

  2. abbottfarm

    abbottfarm Senior Member
    from Maine
    Messages: 108

    Had a similar issue with one of our trucks, it was the light plug where it plugs into the plow right in the front of the truck. Had a broken wire going into the plug, wiggle it around and it would come on. I replaced that part of the harness.
  3. Spool it up

    Spool it up Senior Member
    Messages: 912

    Grandview may be able to help you out
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,745

    you need to see if you have pwr at the bk wire in the plowside headlight,,use a test light and ck for pwr at the plug,,if nothing then you have a broken wire on the plow headgear right after, or at the factory split