1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Driver Side Light not working

Discussion in 'Fisher Engineering Discussion' started by sectlandscaping, Jul 24, 2012.

  1. sectlandscaping

    sectlandscaping Senior Member
    Messages: 314

    I have a MM1 on a 2000 silverado. I had a headlight go out so I bought a new pair. That didnt fix the problem. So I dont know if this is wiring on the truck or the fisher harness? Anyone ever have a problem like this? Or know how to diagnose this?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,930

    Well. Is the tk light out or the plow light out?
     
  3. sectlandscaping

    sectlandscaping Senior Member
    Messages: 314

    Truck light... I checked the fuses. Now I'm wondering what to do now.
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,930

    Ok. Did you ck the plow relays ? Fishers website for the wiring diag
     
  5. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,238

    did you try and unplug the fisher harness and put it back to stock to see if its the truck and not the fisher harness?
     
  6. sectlandscaping

    sectlandscaping Senior Member
    Messages: 314

    tried this today and the lights work stock. So its something with the harness.
     
  7. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,238

    Is it relay or isolation module?
     
  8. sectlandscaping

    sectlandscaping Senior Member
    Messages: 314

    How would I troubleshoot to find out?
     
  9. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,930

    Do you have a big 3 or 4 plug box under your hood,,or just two small relays. Being a mm1 I would say relays
     
  10. sectlandscaping

    sectlandscaping Senior Member
    Messages: 314

    It must be relays because I never seen the box. If it means anything the hi beams do work.
     
  11. sectlandscaping

    sectlandscaping Senior Member
    Messages: 314

    I should be able to switch to the relays to see if thats the problem?
     
  12. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,930

    Yes. Make sure you put the wires back in the same lacal
     
  13. sectlandscaping

    sectlandscaping Senior Member
    Messages: 314

    I found the box today I believe 4 plug. It was buried I have to pull it out. I found 2 fuses both were good. Its been raining the last few days so I havent been able to mess with it.