1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Driver side headlight issue

Discussion in 'Blizzard Plows Discussion' started by SServices, Aug 28, 2016.

  1. SServices

    SServices Senior Member
    Messages: 163

    I have a 8600SW on a 09 Chevy 3500HD my driver side plow light is real dim on low beam and nothing on high beam. The driver side wiring is connected exactly like the passenger side, the passenger works as it should. Could it be the isolator module? I had another new harness that came with the plow and tried it with the same result. I checked in blizzards site and the harness is the correct one. The plow came with the truck when I bought it.
     
  2. bliz&hinikerDLR

    bliz&hinikerDLR Senior Member
    Messages: 471

    Check your two wire plugs behind the headlights. The plugs have an A and B side that makes them reversable. The symptom that you are describing is what happens when the plug is backwards. Rather than worry about A side or B side, just be sure the common (ground) side of the adapter is plugged into the commons side of the harness.
     
  3. SServices

    SServices Senior Member
    Messages: 163

    Thanks for the reply, I did all that. Even changed out the wire harness and the light module, still with the same result, It ended up being a broken common wire in the harness itself.