1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Dodge/Jeep Uconnect

Discussion in 'Ram Trucks' started by 2COR517, Mar 25, 2012.

  1. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    I drive a 2012 Jeep Liberty with the 130S/RES radio, and have a brandy new Samsung Galaxy S Epic 4G smartphone through Sprint. I have the device paired, the phone book syncs up fine, blah blah blah, and it generally works OK. Sound quality on both ends is mulch better than my buddy in his Escape.

    Incoming calls are always OK, outgoing is where the adventure begins. The first call after connecting the each time I start the Jeep is fine. But additional calls may or may not complete properly. What happens when the system fails is this:

    Use the voice command "call home". It verifies that I want to call home. The cell comes alive, and you hear the line ringing through the radio speakers. Then the radio drops out and says the call is complete. But the phone is still working, and the call is continuing. Now I do the mad scramble of trying to get the phone, put it right side up, and say "hello?" about a dozen times in three seconds. I realize the Bluetooth button is still illuminated on the phone. I shut off Bluetooth on the phone and try to continue. By now of course my wife has hung up and swearing to the kids about these new stupid phones.

    Anyone had issues like this, and found the fix?

    I asked the guys at the phone shop. They say it sounds like an issue with the Jeep radio, and I agree.
  2. 90plow

    90plow Senior Member
    Messages: 734

    My mother bought a new cherokee and it does the same thing jeep told her the phone was to advanced for the car very annoying.
  3. Plow More

    Plow More Senior Member
    Messages: 172

    The fix? Dont get the new stoopid phones!!!!
  4. LwnmwrMan22

    LwnmwrMan22 PlowSite Fanatic
    Messages: 27,859

    Do a google for a new ROM for the phone.

    I had to do this for my Droid X2 to work with the Dodge radios back in the day, now the UConnect is compatible with the Razr Maxx I'm running.

    You'll have to root your phone, then do a google for UConnect ROM.

    I know it sounds miserable, but it's quite easy anymore. Plus, once you root your phone, you won't have time to sit on PS, with all the extra things you're going to do to your phone to make it REALLY special.
  5. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    I have a new phone coming next week. Same model without the broken face. If it doesn't work any better I will look into what you are saying. Thanks.
  6. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Fixed the problem. Bought an iPhone. Works perfectly.