1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Die Hard Platinum & Cold

Discussion in 'Truck & Equipment Repair' started by ksgcapecod, Jan 10, 2010.

  1. ksgcapecod

    ksgcapecod Member
    Messages: 52

    I am wondering if anyone else has expierenced the same problem as I have with the Die Hard Platinum batteries. The battery has worked fine for the past 2 years. No problems starting and doing what it supposed to do. This year several times I have gone out to start the truck and it has been dead. I went under the hood and wiggled the negative and then it seems fine. Everything is mounted to the side posts. I did see one other complaint of a similiar natue doing a google search. It seems that the side posts are not directly hooked into the battery somehow and in very cold tempertures will not make a good connection. All the connections are tight so it does not seem like a loose wiring connection. Looking for some insight...may be time for a change, just a hassle to go out and wiggle it when it happens. Thanks guys.
     
  2. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Sounds like a dirty connection?
     
  3. lotec25

    lotec25 Member
    from Florida
    Messages: 47

    I would take it apart and clean them good, just like 2COR517 said. if you have problems after that, Run to autozone or advanced auto and have them run a check on the battery. If there is a dead cell or if it is not being charged properly they can tell.
     
  4. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    Clean the terrminals and have the battery tested. If it's dead, exchange it. Those have 4 year full replacement, I think it is. What kind of temps are you talking about? Mine did fine last winter through a week plus of -45.
     
  5. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    You must be up by Eagle Lake?
     
  6. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    Not that far! Fort Fairfield. That was my first winter back up here in 7 years. I was down in the Calais area for a while. Never gets that cold down there!