1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Diamond 8.5 problem

Discussion in 'Chevy Trucks' started by Motorman 007, Dec 5, 2006.

  1. I posted this in the Diamond/Meyers forum but maybe some of you Diamond/Meyers guys can help out:

    I'm a Fisher guy but I've got a friend here at work who has a 2 year old Diamond 8.5 with the E60H motor. The plow lifts up fine but at the end of the lift cycle, the red light on the control comes on and it stops working. The same condition occurs when you angle right or left and he says he has to reset something to get it to work again. Sorry for the vagueness but I don't know anything about Diamonds. He says he has cleaned all of the electrical connections, both battery and control wiring. Any ideas?
  2. mrbrickman

    mrbrickman Senior Member
    from montana
    Messages: 138

    i have the same prob sometimes, ive had dirty connections where the pump connects to the truck pigtails..

    also its overloaded when the little wire going to the selonoid under the hood comes loose even the slightest bit...

    one other time it did it but the selonoid under the hood went bad.......

    usually it happens in one direction. lately its been the down valve for me, when i hit down the red light comes on, i ended up replacing the coil because it was really weak......now its fine