1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Curtis spreader Honda engine problem

Discussion in 'SNO-PRO PLOW AND ACCESSORIES by Curtis' started by suspended11, Jan 1, 2009.

  1. suspended11

    suspended11 Junior Member
    Messages: 6

    I recently had installed a ts-17 spreader with a Honda motor. I've had a problem starting the motor since day 1. If its a warm day it starts fine. In extreme cold weather it cranks but wont start. The choke seems to be working properly. If i take off the air cleaner and hold my hand over the carb it fires right up. It seems like i have to completely smother it for it to start. Any ideas would sure help.
     
  2. ChevKid03

    ChevKid03 Senior Member
    Messages: 505

    seems to me that if you are covering the air intake and it starts up, the choke ISNT working correctly...
     
  3. Mcouture13

    Mcouture13 Junior Member
    Messages: 7

    Good morning Suspended,
    I just noticed that I had written you a little bit ago, and didn't realize that you wrote this as well after you got your spreader installed. That should not be happening to a brand new sander, ESPECIALLY one with a Honda engine!!!! I'm willing to see if we can't fix the problem, and get you up and running again, with a better view of Torwel's commitment to customer service