1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Curtis plow won't stay up

Discussion in 'SNO-PRO PLOW AND ACCESSORIES by Curtis' started by PlowGuy314, Oct 10, 2010.

  1. PlowGuy314

    PlowGuy314 Junior Member
    from CT
    Messages: 17

    So I picked up a 8' Curtis plow today from a guy for $500. It turns, it lifts, but it doesn't want to stay up when its lifted up. It stays up for a couple seconds before dropping down to the ground again. Everything else is fine with it though. The only other problem with it comes in on my end, on the truck end. I have a Curtis plow frame on my truck already and thats all fine, but I also have wiring for a Curtis plow and I went to plug it in today and the end of my wiring on the truck side is different from the end on the plow side. On the truck side the end is rectangular and then angled off on one corner and on the plow side, the end is just plain rectangular. It doesn't fit at all. So do they have some sort of adapter I could just use or do I have to run new wire? So once I get those two things figured out I'll be off and running in anitcipation of snow like the rest of you guys! Thanks guys.
     
  2. amocerino

    amocerino Senior Member
    from 01606
    Messages: 177

    You will need a new harness we went to a double plug harness 5 years age and on the plow going down the float valve might need to be cleaned or replaced.Any questions call Angelo at 1-800-343-7676 ex3042 Thank you.
     
  3. PlowGuy314

    PlowGuy314 Junior Member
    from CT
    Messages: 17

    Thank you for the response. I went to my local Curtis dealer and got the double plug wiring harness for the truck and hooked it up tonight. Everything seems like it should work. Pull up to the plow, plug in the wiring, the controller, turn it on, try moving up or any direction for that matter, and I get nothing. I can hear the pump running when I try it, but the plow doesn't move at all. The fluid is full, but could it be overfilled? The solenoid on my truck might be bad for all I know since that is the only non-new part on the system. Could this be all it is? Thank you.
     
  4. amocerino

    amocerino Senior Member
    from 01606
    Messages: 177

    Check if you have power at the coils in the aframe the orange wire is the ground for the coils
    red lift
    green float
    blue left angle
    white right angle
    pink jack retract
    blue w/black jack extend
    They will have power when you put them in that function.
     
  5. PlowGuy314

    PlowGuy314 Junior Member
    from CT
    Messages: 17

    Thank you. I'll be checking those first then.