1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Cruise control and overhead console quit working....

Discussion in 'Ford Trucks' started by gotsnow?, Dec 8, 2011.

  1. gotsnow?

    gotsnow? Senior Member
    Messages: 257

    In my 02 Excursion my cruise and my overhead console both stopped working at the same time. I noticed no problems with either of them one day, and the next day I go start up my excursion and the overhead console is dark (I always have it on to temp and compass) and the cruise control indicator light will show on the dash when I turn it on, but will not set (lock in my speed). I tried parking and shutting off and restarting my truck with no luck. Are there fuses for either of these creature comforts? I have checked the owner's manual's list of fuses and it shows me nothing for either component. Is it possible the cruise and the overhead console or tied together somehow and the same problem effected them both??
    Please help. :confused: I don't know what direction I'm going, how cold it is outside, and can't keep a steady pace!

    Thanks, David - got snow?
     
  2. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    Buy the single model repair manual for your truck at Advance or AutoZone. It's like $25. The book gives you more information and wire diagrams. Can't read them? Find a friend that can. The owners manuals are just about useless. They do list what fuse controls what component. Most of the covers for the relay or fuse boxes have the number / location for the fuse printed on them.Most newer Fords have a fuse box in the dash and another fuse / relay box under the hood.
     
  3. firefighter1406

    firefighter1406 Senior Member
    Messages: 328

    I know it sounds crazy. But for the cruise check and see if your third brake light is out. If it is replace it and see if that fixes it. I wouldn't say anything but that is what was wrong with my dads cruise in his f250
     
  4. gotsnow?

    gotsnow? Senior Member
    Messages: 257

    Well i do have that manual, I had just started with the fuses cause that seemed like the easiest place to start. I guess ill have to start following wires, or check the 3rd brake light.... Also, I figured out the overhead console issue, I had only been using it at night and with auto lights on I hadnt seen the overhead console without the dash lights dimmed until today. I guess the last person turned down the dimmer just enough that the overhead readout was off, now that I have them turned back up a little it works. just have to chase the CC issue.
     
  5. firefighter1406

    firefighter1406 Senior Member
    Messages: 328

    I bought the third brake light was crazy too but it worked. The only thing I can think of is that it is tied into the cruise in the fact that you hit the brakes and the cruise goes off. So the blub being blown would leave the circuit open. I don't know if that is right but that is what I am thinking.
     
  6. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    The Cruise Control units do fail, but not very often. Could even be a PIA issue like the switches. A Professional / Shop manual at a Bigger / Main library may have more info on Cruise Control issues. They have them, you may have to order them brought up from the basement or from down town storage. Or they may even have Internet access to a Motor's or Chilton's's on demand account. You could start pulling junction plugs apart and putting dielectric grease in them before you connect them again. This may cure the problem. Clean and protect all your ground connections. This may cure it too.
     
  7. gotsnow?

    gotsnow? Senior Member
    Messages: 257

    Third break light is already working... That could have been a very easy fix if only. I guess Ill start checking connections. What REALLY gets me is when I turn the cruise control on and press the set button the green idiot light comes on on the dash board.... Just doesnt hold speed. So part of it works and part doesnt.
     
  8. alldayrj

    alldayrj PlowSite.com Addict
    Messages: 1,096