1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Couple unimont questions

Discussion in 'Western Plows Discussion' started by RH31379, Jan 4, 2011.

  1. RH31379

    RH31379 Member
    Messages: 32

    I have a unimont, 6'6" on my 87 jeep wrangler.
    couple ? on some issues I have had.

    1. last week during the blizzard the plow seemed to freeze up, made a loud like grinding noise then hardly moved. I hadnt doen the annual fluid change yet, hadn't had time. ended up changing it in the middle of the storm and then blew a line... change again...lol. It seems to be fine now, is there an additive that can be added to help the freezing? I used the blue western fluid, now i have red fluid from the well known local dealer.

    2. my quadrant sector keeps breaking the u channel under the left piston. We keep welding it, I assume we're getting good weld cause nothing else we weld breaks but this piece has broken 2 time last year and 1 this year, I go through alot of angle pins since they keep bending. When I bought this plow the same side was broken off. I wonder what may cause it?
    I also notice some stress cracks on on the steel angle in the area of where the pistons mount to the quadrant.

    My real ? here is I have an old convential mount plow, same size. will that quadrant fit the unimont? it look like it should?

  2. mrdeere160

    mrdeere160 Junior Member
    Messages: 8

    I run standard atf in all my western plows and have never had any problems with freezing, something is bent putting too much strain on that bracket, yes the conventional to a frame will work on the unimount