1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

conventional problems

Discussion in 'Western Plows Discussion' started by ommegang, Dec 16, 2007.

  1. ommegang

    ommegang Senior Member
    from wi
    Messages: 100

    I have this western conv that was slow after several hours of use so, I got a new filter screen and flushed the pump and side rams out, pump was very dirty on bottom and screen. flushed with kerosene then with tranny fluid to get kerosene out, in the side rams. Then put 2 qts of blue fluid in. I only had two, manual says 2 1/8 anyway, I think it's a littler low which I will rectify tomorrrow but, it now makes a pronounced noise when I move the joystick in any direction and didn't want to move at all on two occasions. I noticed two times a spark from the battery line going to the motor while plowing. I wiggled this and then I got movement. But, still heavy noise upon joystick movement. Any insight?

    Thanks,

    Lance
     
  2. ommegang

    ommegang Senior Member
    from wi
    Messages: 100

    New pump and motor - $350.00, including one hour paid labor - I can live with that. The shop said that they won't even look at cable operated systems anymore due to the fact that one problem leads to another. So, I'm lucky that they even looked at it. But, it works great now! And, my thread will help, I'm sure.

    Good plowing.

    Lance