1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Controller problem staying on

Discussion in 'Western Plows Discussion' started by snowplowpro, Dec 25, 2010.

  1. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    I have two western controllers and they both werk put new cords on them and even before i changed the cords they both shut off automatically why does this happen what can i do to stop it from shutting off. Or is it truckside.
     
  2. MarkEagleUSA

    MarkEagleUSA Senior Member
    Messages: 321

    The handheld controls automatically shut off after 20 minutes of inactivity. Or are you having a problem with them staying on to begin with?
     
  3. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    Lets say i go and angle plow after like a couple seconds it will go this is no 20 minutes its seconds
     
  4. MarkEagleUSA

    MarkEagleUSA Senior Member
    Messages: 321

    Handheld or joystick control?

    The UltraMount mechanics guide has this note about the handheld:
    Sounds like you have a bad connection somewhere.
     
  5. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    Thank you very much for your help good luck plowing and happy holidays i will check that out asap
     
  6. 01lariat

    01lariat Member
    Messages: 96

    I thought I was having the same issue with my MVP control. Turns out it was my big thumb and inexperience with the controller. I'd simply brush across the power button myself, while in use, not realizing it.
     
  7. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    loose wire truck side

    i figured it out i was moving my hand and the wire from the truck side is loose some were now i got to get in there and search for a loose wirepayupThumbs Up
     
  8. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Check the plug in connector, or check inside the controller itself.....

    Also check between the firewall to make sure the wires are not damage..

    The controller also has a ground wire..
     
    Last edited: Dec 27, 2010