1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Controller dysfunction

Discussion in 'Western Plows Discussion' started by bslms, Jan 21, 2013.

  1. bslms

    bslms Junior Member
    Messages: 4

    We have an 8', Ultra-mount V that is respomding incorrectly to the controller inputs. For example: push to angle left and the plow responds by going into scoop mode. The worst is the blade will not lift.

    The plow will respond to every input just not the input desired. The pump motor and solenoid seem to be functioning properly, the plow is just not getting the correct information.

    We had the plow in the shop before the season and they put in a 'Pin Kit'. The plow worked great until it didn't.

    Any thoughts on where to start looking?

    Thanks,
     
  2. nealybird

    nealybird Senior Member
    Messages: 714

    is it an MVP plus? (with the plastic covered power unit) If so, there are 4 fuses out there on the power unit. If someone inadvertently plugs the power cord in backwards some of them will blow, and you will get strange reactions to the controls until you replace them.
     
  3. bslms

    bslms Junior Member
    Messages: 4

    Thank you for that info, we will look for that next. Fingers crossed...
     
  4. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    I plow with a guy who had the same problem you have. I took off the cover and look at the fuses. Both 4amp fuses were blown. I ask him what he has done, and he told me that him and another worker were changing the fluid. Come to find out the worker try to reconnect the power plug and put it on backward..

    Really look at the 4amp fuses just to be safe..
     
  5. bslms

    bslms Junior Member
    Messages: 4

    Thank you Twinman. We pulled those covers when we first mounted the plow last fall just to see what was under there. I don't remember seeing any fuses there but we will check again tomorrow.

    The schematics on the online Western site don't show those fuses ( or I just don't see them). We will do a closer look tomorrow.
     
  6. nealybird

    nealybird Senior Member
    Messages: 714

    they are in the harnesses that go to the coils. two harnesses part # 28581-1 and 25583 each have one fuse holder with a cover, and each of them have two mini fuses in them.
     
  7. bslms

    bslms Junior Member
    Messages: 4

    Thanks again, Neally.