1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

controll box

Discussion in 'SnowEx Products' started by lucky921, Dec 31, 2012.

  1. lucky921

    lucky921 Senior Member
    from dracut
    Messages: 453

    have a snowex 6000 having trouble with work fine now it codes oe all lights on turn power on off a few times it works ok but with liberator on it kills all power like breaker popped need help thanks
     
  2. nrplowguy

    nrplowguy Senior Member
    Messages: 130

    Um check your spelling so we can under stand what you are saying!!!!!!!!
     
  3. lucky921

    lucky921 Senior Member
    from dracut
    Messages: 453

    when i turn sander on i get the EO code. then it works after turning on and off a bunch of times it works. while it working and turn on the vibrator it turns of after waiting a little bit and turn it back on it works then it will shut down after a few minnutes
     
  4. mn-bob

    mn-bob Senior Member
    Messages: 132

    You should start by making sure you have good clean connections
     
  5. lucky921

    lucky921 Senior Member
    from dracut
    Messages: 453

    found the problem it was loose connection on the back of the box. the shut off problem was bad breaker