1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Connector question?

Discussion in 'Blizzard Plows Discussion' started by deluxeco, Nov 27, 2005.

  1. deluxeco

    deluxeco Senior Member
    Messages: 115

    Finally able to use my new 810.The driver stated that the electrical plug
    kept disconnecting during the night ,more so when using the scoop position.
    Has anybody experienced this problem and if so what is the solution? The connector is located under the bumper and wire-tied to the tow hook on a 2004 chevy,as per the installer. Thanks
  2. Detroitdan

    Detroitdan PlowSite.com Addict
    Messages: 1,937

    that's how I did mine, already broke the wire tie and havent even plowed yet. I'm going to pull it out a little and resecure it with bigger wire tie. Shouldn't need much slack.
  3. SnowGuy73

    SnowGuy73 PlowSite Fanatic
    Messages: 24,868

    Thats the same way mine is on my Dodge, have'nt had any problems with it coming off though.
  4. fastjohnny

    fastjohnny Senior Member
    Messages: 653

    Try this

    leave it loose or use a bunge to hold things together
  5. rcpd34

    rcpd34 Senior Member
    from MD
    Messages: 662

    I wire tied mine to the left tow hook and left about 4" out. Never come undone in 3 yrs.
  6. Ice Scream

    Ice Scream Member
    Messages: 82

    Mine comes undone when the snow builds up on the covers. I talked to blizzard a little while ago and they recommend it be left loose with slack.