1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Confused on Allison Tranny Problem...2002 2500HD

Discussion in 'Chevy Trucks' started by bigben50, Jan 10, 2009.

  1. bigben50

    bigben50 Junior Member
    Messages: 5

    Hey guys,

    This is my first time posting on this site, but I have browsed it many times before. I am hoping someone might be able to point me in the right direction.

    First off I have a 2002 2500HD with the 8.1 liter big block. It has the Allison Trans. Today I encountered a problem with my shifting that I thought I fixed 2 months ago by replacing the Neutral Safety Switch. I have only had this happen twice once last year and now today. Both times there was 12'' snow plus.

    1.)Here is list of problems that has happened both times....Check Engine Lite comes on, and the truck begins to shift very clunky. It will also occasionally pop out gear when driving in reverse. The truck seems to be stuck in third gear any time I am moving forward. The truck always starts off in 2nd and it will not shift into Drive or Overdrive even when I am traveling 45mph. Therefore both times I had to limp the truck home doing 30mph. Also as far as display, The shift indicator (P,R,N,D,3,2,1) will only backlite (P,D,3) when I am in neutral, reverse, 2,1 there is no back display. When I put the truck into neutral you can feel it is not in gear but it will not indicate it on the dash, the same goes for reverse. When I place the shift lever 3 clicks down, meaning neutral, I am still not able to put the truck into 4WD low. As you can see there are many things that my truck is getting confused on. Oh and also we hooked the truck up to a diagnostics reader and it stated the "pressure switches" are stuck, faulty, or bad connection. The numbers of errors it pulled were; 872, 847, 875, and 700. I have printed out the conclusions of these but they all seem to be similar.

    2.) Solutions that I have tried......Last year I let the truck sit for about 3 hours and went back in it and everything worked fine. This year I didnt have the kind of time so I crawled under the truck and removed any snow/ice from around any electronics near the Transfer case and Tranny. That did not work. I put it on a lift unconnected all electronics, made sure they were dry and reconnected. That did not work.


    3.) So right now the truck is sitting and I cant solve this problem. Any advice would be appreciated.


    Thanks So much and Happy Plowing...


    Ben DiMarco
    Akron, Ohio
     
  2. JD Dave

    JD Dave PlowSite Fanatic
    Messages: 11,045

    NSBU switch on left side of tranny.
     
  3. bigben50

    bigben50 Junior Member
    Messages: 5

    THANKS!!! But a few questions.....Is it hard to replace? Do they sell it at your everyday auto parts store or is it just through GM? About how much they cost?
     
  4. bigben50

    bigben50 Junior Member
    Messages: 5

    Also this is the Neutral Safety Switch correct? Is it unusual that I replaced this November 25,2008. Just over a Month OLD??? Sounds crazy it would go bad so quick?
     
  5. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Its your neutral start back up switch. I replaced mine this past summer cost me 80 bucks, and took me about 30 min at most to do. There is two electrical plugs, and two bolts if I remember right. Truck has to be in neutral to do this also, so make sure to use your e-break, and a good wheel chock so you don't get crushed. Personally if it were me I'd go to a diesel machanic, or a dealer, to get the part. I'd shy away from a autozone NSBU switch. Thats just me tho.
     
  6. musclecarboy

    musclecarboy 2000 Club Member
    Messages: 2,303

    Costs $268 up here to do. Replaced mine in Nov. Put the truck in N, unscrew it all, pull like a crazy bast to get it off, pop in the new one (make sure that little steel alignment thing is off!) then bolt it all back up. Check engine light might stay on for a bit, mine cleared itself after 2-3 start-ups.
     
  7. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592


    I didn't do that to mine, was I suppost to?




    HAHAHAHAHA! just kidding
     
  8. bigben50

    bigben50 Junior Member
    Messages: 5

    Thanks for all your help! Greatly Appreciated....I am going to get the autozone part so I can plow the rest of the night and buy the OEM one or the one from diesel website this week.


    Another weird note I tried the tuck after letting it sit for about an hour. Still a clunk tranny and no light indicators for R,N,2, and 1, but I had all 4 gears. 1st through drive. got her up to 65 and came home.



    Ben DiMarco
     
  9. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    The clunk could be a u-joint going out also. How many miles are on the truck? I had both of mine replaced on my 04 D-max last spring. Not sure why they went out but I think it had something to do with the 700 pounds of balast I had in the back of my truck, and plowing all my accounts by myself. 18 hours worth of work almost everyday. We got rought 12 feet of snow last year. I don't know, I had a squeak in mine tho, no clunking.
     
  10. bigben50

    bigben50 Junior Member
    Messages: 5

    Bought the part at autozone last night 10 minutes before the closed. Took me about 30 minutes to replace it. Thanks for all your help you guys!!!
     
  11. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Where did you purchase the first NSBU switch from that you replaced just two months ago?
     
  12. rcpd34

    rcpd34 Senior Member
    from MD
    Messages: 670

    Should not fail that quick. You may be able to get it replaced under warranty.
     
  13. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,566

    what color was the NSBU that you pulled out. was it a tan one? That is weird to hear of a tan one crapping out that quick.