1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

CJ& Hydraulic Clutch

Discussion in 'Jeeps' started by Flipper, Apr 11, 2012.

  1. Flipper

    Flipper PlowSite.com Addict
    from CT
    Messages: 1,180

    Working on an old CJ with a hydraulic clutch. Guy ran it for 15 years on the same clutch, master and slave. Two months ago his clutch started to go and the extra pump of pedal etc wore out master/slave. Together we replaced the clutch with the same type he had as well as master and slave. Bench bled and bled system on vehicle. We immediately had a problem with clutch grabbing right off the floor, almost no pedal, jeep would creep forward. Tried bleeding numerous ways went through quarts of fluid but could not get it figured out.

    Finally we decided to get another master. Bench bled it installed it, bled system on vehicle and the guy said it was the best it had felt in years. Clutch grabbed mid-pedal, engagement was felt as soon as you started to depress pedal. This proved that the inner workings of the clutch were great.

    Well last night he had to be towed as pedal was once again doing nothing. Master shot, fluid is dark grey almost looks like full of metal shavings. Blew out line and slave, ordered new master. Went through all steps as above and while clutch is working we have an extremly low pedal and fluid is once again metallic gray.

    So we are getting another master tomorrow. I am puzzled, what am I missing? Just bad luck with parts? Master is aluminum castings as it always was, slave is cast steel. Running normal brake fluid as it said to. I am going to take failed master apart tomorrow and see if I can notice anything. This guys beatifully restored CJ is literally sitting now due to what should be a simple sytem of master, 2 ft of line and a slave.
     
  2. theplowmeister

    theplowmeister 2000 Club Member
    from MA
    Messages: 2,549

    sounds like you got it. As long as your not lousing fluid it has to be the master
     
  3. Flipper

    Flipper PlowSite.com Addict
    from CT
    Messages: 1,180

    Just can't believe the quality in parts. ! in 5 is good but then only for 2 months.

    We ordered from a different place and a different brand. We'll see.
     
  4. theplowmeister

    theplowmeister 2000 Club Member
    from MA
    Messages: 2,549

    It can be bad

    that is what happens when price is the driving factor.
     
  5. Flipper

    Flipper PlowSite.com Addict
    from CT
    Messages: 1,180

    I guess it just depends on what factory in China it comes from.
     
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    I went though that with fuel pumps on my 4.2L. they either didn't work or worked for 70/100 miles then quit. Made me so paranoid when I got one that worked for a couple months I took it off and bagged it, install another one on the jeep. I figure they are easy enough to change I'll just carry a confirmed working spare.

    Tough to do with a clutch system though