1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Chevy S-10 , Homesteader Install, LIGHTING HELP NEEDED

Discussion in 'Fisher Engineering Discussion' started by Nascar24, Oct 24, 2009.

  1. Nascar24

    Nascar24 Senior Member
    Messages: 645

    I installed a Homesteader on a 2000 Chevy S10 today, everything went pretty smoothly until I wnet to get the lights going.

    Just some background info to help sort things out


    Truck Headlamps HB3/HB4
    Module # 26400, 4 port module used
    #1 Port Control Harness used
    #2 Port module to plow light harness used
    #3 Port Headlamp harness 26361- 1 new
    #4 Port Headlamp Harness 26360-1. new
    .
    When I intially hooked things up the left low beam on the truck was not on , so I re-configured the configuration plug, light came on, plugged the plow in had headlamps, high & low beams, had right turn signal, when I put the left turn signal on I got the right signal again!

    I tried another used module I had, got the same results, I tried another #2 harness, got the same results. I also had a new set of plow headlamps tried them , same results.

    Any suggestions? I'm kinda stuck and I need to get this back to the owner late tomorrow.

    Thanksin advance for any assistance.

    Jay
     
    Last edited: Oct 24, 2009
  2. Nascar24

    Nascar24 Senior Member
    Messages: 645

    I'm all set,

    DAH I guess when you hook the left signal to the parking light circut, you get both right and left directions on the plow flashing :dizzy:

    Jay