1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

chevy misfire issues

Discussion in 'Chevy Trucks' started by NickT, Jun 23, 2011.

  1. NickT

    NickT Senior Member
    Messages: 707

    Hey guys my trucks in the shop getting trannie lines replaced and rear brakes they were rusted go figure. Anyway, I had the mechanic run a scan for a check engine light and they're telling me it reading a misfire on four different cylinders. Possibly a crankshaft bearing or tourque converter problem. I thought maybe just plugs and wires but he's saying that would be the case if only 1 cylinder was misfiring. Just wondering if anyone else has had these issues. Truck is an 04 silverado 2500 with 130,000 miles thanks
     
  2. BlizzardBeater

    BlizzardBeater Senior Member
    from Maine
    Messages: 420

    I would really question the mechanic that jumps to a crank bearing or torque converter. Is it a random/multiple cylinder misfire, or four individual codes on four individual cylinders? What exactly are the codes. How was it running before it went to the shop. Any lights on and how long have they been on. What motor and repairs, if any, have been made. Info is key here. Get us everything you can and someone will be sure to help! :)
     
  3. 04ram1500

    04ram1500 Member
    Messages: 97

    I had a 1999 Silverado with 95,000 mi. that had a misfire on 3 cylinders. It turned out that the fuel rail was 99% clogged. Took it all apart, cleaned it and everything was like new. I think it would be worth it to check for a fuel problem first.
     
  4. RacingZR

    RacingZR Senior Member
    from Maine
    Messages: 399

    Time for a new mechanic........
     
  5. NickT

    NickT Senior Member
    Messages: 707

    I will be picking up my truck Saturday, will have the codes then. I didn't get the impression the mechanic was jumping to repair the crank or torque converter he was giving me scenarios. The truck is running ok but hesitates when u hop on the gas . The check engine light is on but flasahes when I acclerate like going onto the highway from a on ramp
     
  6. NickT

    NickT Senior Member
    Messages: 707

    thanks in advance for your help fellas. I'm decent with mechanics but don't do it everyday. Unless there is 6 " of snow on the ground lol
     
  7. NickT

    NickT Senior Member
    Messages: 707

    6.O engine
     
  8. 70monte

    70monte Senior Member
    Messages: 468

    If you have 130,000 miles on the original plugs and wires, you definetely could have multiple misfires on different cylinders from this. Bad fuel injectors or coils could cause the same. You could move your coils from the cylinders that are misfiring to the ones that are not and see if the misfires follow the movement. This should rule out your coils if nothing changes.

    I would do a plug and wire change if they are original and see if that fixes the problem.

    I highly doubt what your mechanic has suggested is the problem. I think you would have some other symptoms other than misfires. Probably some noises that are not normal and maybe some oil pressure issues caused by a bad bearing.

    I put my scanner on a friend's 2000 tahoe with the 5.3L that showed multiple misfires in a couple of cylinders that turned out to be two bad fuel injectors and it had similar mileage.

    Wayne
     
  9. 2004chevy2500hd

    2004chevy2500hd Senior Member
    Messages: 123

    Agree with these other posts - get the error code and then do some research.

    I have an 04' 2500HD 6.0L and it sees a P0300 error when I am doing highway hauling (with a trailer)- I then drive the truck for a while w/o the trailer and the check engine light disappears....it's been happening for a while...from other posts I've read - I'm not alone.

    Keep us posted.
     
  10. 70monte

    70monte Senior Member
    Messages: 468

    I just remembered that the last time I put my scanner on my 98 K3500 with the 7.4L, the scanner showed misfires on different cylinders and the CEL has never came on. I know the CEL works because it lights up when you first turn the key on. Mine has a complete tuneup with plugs, wires, coil, and a new distributor. It does kind of idle rough but smooths out when you drive it. Mine could be fuel injectors since they are known for leaking and causing problems even though the truck starts right up, even after sitting for days.

    Wayne
     
  11. NickT

    NickT Senior Member
    Messages: 707

    Hey now! Thanks for the input guys. Regarding the misfire issue my invoice says "multiple misfire codes stored,oxygen sensor code. Has crankshaft correlation issue causing misfire. They didn't give me the actual codes which really ticked me off I will call tomorrow to get some answers. The truck is idling and running good will probably start by replacing the plug wires. Is seafoam a good thing to try?
     
  12. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    Bingo the crankshaft correlation has and will always be a problem with random misfires on these motors Someone will need to preform a crankshaft varation relearn procedure. I do them all the time and should be done at reg intervals to keep the light off. PS find a new mechanic quick.
     
  13. NickT

    NickT Senior Member
    Messages: 707

    Can you explain the crankshaft variation relearn procedure? Thanks, Nick
     
  14. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    U need a scan tool to do the re learn procedure. Its a very common issue on these trucks .The whole process takes about 4 min at most.
     
  15. mycirus

    mycirus Senior Member
    from Mass
    Messages: 589

    My old 6.0 used to flash the check engine light at me all the time and threw misfire codes. I got the relearn done and it was great after that.
     
  16. NickT

    NickT Senior Member
    Messages: 707

    Thanks for the input everyone I will change the plugs and wires and have the relearn done. I will post results just don't know when. Nick