1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

chevy light issue

Discussion in 'Fisher Engineering Discussion' started by wallyiv, Nov 29, 2011.

  1. wallyiv

    wallyiv Junior Member
    from maine
    Messages: 8

    i am having trouble with my lighting on my 05 2500 hd. i traded my 03 1500 and got a 05 2500hd. i switched over my fisher plow setup and wired it up. now that it is wired up my low beams do not work on the truck just high and all marker lights and blinkers. can anyone help i tried flipping wires and i rechecked to make sure i spliced the right wires. the only thing i can think of is maybe i need a new module for this truck? by the way its a mm2 with a 3plug 4 port system.
     
  2. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    What wires did you try to flip? Unplug the factory low beam plug from the plow harness, plug in backwards. The plugs may not clip like they should, that's ok for now. Do the lights work as they should after doing that?
     
  3. wallyiv

    wallyiv Junior Member
    from maine
    Messages: 8

    i triedswitching the high and low beam wires. i will try fliping wires around. thanks
     
  4. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    Just flip the low beam plug. If that works, then you can take the plug apart and flip the wires.
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Did you plug in the right plugs? All the harness are the same. Are you sure it came of a 03 and not an 02??
     
  6. wallyiv

    wallyiv Junior Member
    from maine
    Messages: 8

    i switched plugs and the low beams work but high doesnt now. i called fisher and checked if my wires were good for a 2005. they said the wires that i have are for a 2002. he said i can use the harnesses but i have to make sure that the blue wires in the plow side match up to the comon on the truck side.has anyone done this befor and maybe could give me some helpfull hints? thanks
     
  7. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    What plugs did you switch? My plow is on an 06 and it came off of an 01. I believe the wire colors matched up between plow and truck harness.
     
  8. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

  9. wallyiv

    wallyiv Junior Member
    from maine
    Messages: 8

    problem fixed...all 4 plugs need to be flipped now both high and low beams work. thanks for all the feed back.
     
  10. speedydivito

    speedydivito Junior Member
    from CT
    Messages: 3

    I'm having the same problem so hopefully you can help me. I have an 03 2500 HD and I bought the truck with the plow. High beams stay on all the time and all the other lights work. When you say you flipped all 4 plugs, do you mean you swapped out the low beam connection to the high beam? Or do you mean on the low beam, you flipped the wires, then on the high beam you flipped those wires? Thanks for any help!!
    Thanks, Danussmileyflag
     
  11. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    there is your answer.
     
  12. speedydivito

    speedydivito Junior Member
    from CT
    Messages: 3

    Thank you, I should have read that through the first time!! I will take it apart tomorrow and hopefully I can resolve it with that.

    Thanks for the help!!
    Danussmileyflag
     
  13. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    's alright glad to help.


    Welcome to plowsite:waving:
     
  14. speedydivito

    speedydivito Junior Member
    from CT
    Messages: 3

    Just got down redoing all the wires and like magic it worked!!!! Thanks a ton!! That's not something I would have figured out by trial and error! LOL!! Would have definitely been a visit to the Fisher retailer down the street. Thanks a bunch!!
    Danussmileyflag