1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Changing Plug (Boss RT2)- HELP

Discussion in 'Truck & Equipment Repair' started by anythinglabor, Mar 3, 2014.

  1. anythinglabor

    anythinglabor Junior Member
    Messages: 9

    Broke a few wires on my plug (been getting stuck all week)

    - Finally had time to replace it tonight, got 10 (out of the 11) wires working.
    Previous issue - Up didn't work,
    Current Issue - Down wont work.....

    When I stripped the wire (orange) the copper appears dark or burnt - the down worked prior me even replacing the plug, I've never really had a problem with the down AT ALL...

    What could be the problem here? Like I mentioned, the wire appears dark as if the copper is almost burnt or something... Is it possible (that within the 5 minutes I cut the wires & attempted rewire) it some how shorted out or is no longer good?? I'm dealing with some pretty old stuff, but I just don't see that wire going bad within the process......

    any input appreciated in advanced.

    - Tim
  2. derekbroerse

    derekbroerse 2000 Club Member
    Messages: 2,377

    Are you talking about black corrosion? Miserable stuff. Solder won't stick to it, contact is mehhhh at best.. hate it.

    You can literally sand it off, though, using sandpaper and a little wooden block...