1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

changing fluid on a ezmount xpress

Discussion in 'Meyer / Diamond Products Discussion' started by bobcatnj, Oct 4, 2007.

  1. bobcatnj

    bobcatnj Member
    from NJ
    Messages: 48

    how do you change the hydo fluid on a ezmount express? where the drain plug?
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Pull the plastic cover box off the pump unit. On the front of the pump unit, down near the bottom there will be 2 hex head plugs.One should be marked "Drain". The other one won't be marked but remove it too as there's a filter behind it for the A valve that you'll want to clean while your servicing the system. Drain and flush the entire system including the angle cylinders and hoses and the attachment cylinder and hoses.
     
  3. bobcatnj

    bobcatnj Member
    from NJ
    Messages: 48

    dumb question, but how do you drain the angle and hoses? any tips on changing the fluid.it seems pretty easy, i just dont want to mess it up
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If you disconnect the hose's at there lowest point, like right at the cylinder, they'll drain on their own. To remove the fluid from the cylinders, I uses a vacuum pump and place the end of the suction hose directly inside the hose port in the cylinder right where you disconnected the angle hose from. But, you can also remove the cylinder and pour the fluid out that way.
     
  5. bobcatnj

    bobcatnj Member
    from NJ
    Messages: 48

    thanks for the help i'll give it a shot