1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

cant fuel up

Discussion in 'Chevy Trucks' started by nelson4047, Jul 22, 2009.

  1. nelson4047

    nelson4047 Member
    Messages: 31

    when trying to fuel 05 silverado 1500 it keeps kicking the gas fill off as if its not venting right. the vent is free (can blow through it) i took the main fill hose off all the way to the tank & its open with the exception of the ckeck in the tank & it doesn't look to have any foreign stuff on it. if i tilt the handle on the pump just right it will kick off 1 or 2 times then fills fine sometimes. pretty frustrating standing at the pump for 25 minutes any ideas would be great
  2. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Try pulling the pump handle out an inch or so. And use the second notch to hold the handle.
  3. nelson4047

    nelson4047 Member
    Messages: 31

    doesn't seem to matter where i position the handle still kicks off at least once or twice every time even on the slowest setting
  4. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    And it's doing it at different pumps/stations?
  5. nelson4047

    nelson4047 Member
    Messages: 31

    don't matter which station, i thought about taking a punch & knocking out the check in the tank but not sure what other problems might arrive (evap or something)
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The EVAP cannister vent valve is stuck closed which prevents the tank from venting while filling. It is a rather well know and common issue and GM did release an updated kit to address the problem but your truck is new enough it should already have the updated components. So simply replacing the current valve should fix the issue.
  7. jperry9636

    jperry9636 Member
    Messages: 45

    I had the same problem. Just got the new kit for my truck. It took about 20 minutes to put the new can in and run the vent up over the tranny.

  8. got-h2o

    got-h2o 2000 Club Member
    Messages: 2,439

    Damn B&B you're always beating me to it! I read the titles, think, hey I can help......then there you are!!!
  9. Longae29

    Longae29 PlowSite.com Addict
    Messages: 1,954

    just hold the handle at 90 degrees to the tank works also.....
  10. nelson4047

    nelson4047 Member
    Messages: 31

    thanks b&b it does have a vent code in it but didnt think it would affect filling the tank i will give it a try. i have had older trucks with the same evap problem & put the kit in but didnt fix the code problem
  11. samjr

    samjr Senior Member
    Messages: 480

  12. nelson4047

    nelson4047 Member
    Messages: 31

    yep the canister was full of dust, just blew it out and seems to be fine for now. thanks