1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Can someone help w/ lights...MM2

Discussion in 'Fisher Engineering Discussion' started by Raymond S., Jan 29, 2008.

  1. Raymond S.

    Raymond S. Senior Member
    Messages: 513

    My headlights are not coming on at all when plugged into the truck. My turn signals are working but that's it. I cleaned both sides of the plug, nothin. After reading on here all night I am left to wonder about the isolation module. Is there a good way to test this? I read someone say to jump #2 and #7 on the female side of the plug but there is nothing in the #7 terminal. This is on a '96 F250. Any help would be appreciated.
    Thanks,
     
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    http://fisherplows.com/pdf/27179_070001.pdf


    I am thinking no power to the running lights (you don't have those on plow side either) Second wire on driver side, brown IRRC, may not have contact with scotch lock, or may have been to ground, if so my bad, sorry.

    Lets check that first, maybe just jump it to bat and see if you get plow lights.
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    So all you have on the plow side is turns, no hi/low beam or parking lights?
     
  4. Raymond S.

    Raymond S. Senior Member
    Messages: 513

    that is correct. Just turns

    John, I do remember that lock having to snap a 2nd time. I'll check that when I get home.
     
  5. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Just to let all know, we talked on the phone tonite, problem solved.
    It was the brown running light wire not making contact.

    Some ground connections also got cleaned up and all is well.
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Good to hear you guys got it all fixed up. :)
     
  7. Raymond S.

    Raymond S. Senior Member
    Messages: 513

    yep, all is well.
    Thanks again John