1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Can not raise or angle but does lower.

Discussion in 'Western Plows Discussion' started by ppandr, Dec 16, 2008.

  1. ppandr

    ppandr Senior Member
    Messages: 619

    Went out tonight and having issue with blade not raising or angling. Lowers and I can here the seloniod clicking when I try it (motor not running). If I drive with blade down the vibration seems to free the problem. I am thinking seleniod might be bad or there is a loose ground somewhere. Any advise...heading back to shop at 4am to sort out. Electro not iso....

    Thank you in advance.....
     
    Last edited: Dec 16, 2008
  2. sechracer

    sechracer Senior Member
    Messages: 478

    If vibration fixes the problem, I would look at the grounds on the plow side, but for sh!ts and giggle, next time it does it, try jumping power to the motor from the battery or solonoid and see if the motor runs.
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If you find all connections and motor grounds good, then either the motor or the under hood solenoid is shot. Using Sech's jumper method when it goes down will tell you which one it is for sure.
     
  4. wahlturfcare

    wahlturfcare Senior Member
    Messages: 320

    i would also check to see if your plows fluid is freezing. it is happening here alot to guys. if the blade has little tension on the chain, the pump works great. but if you try to do anything with tension on it it wont move.
     
  5. grow50

    grow50 Junior Member
    from vermont
    Messages: 3

    I am having the same problem. Did you get the problem fixed? If you did what was it.
     
  6. CJPlow

    CJPlow Member
    Messages: 54

    that makes 3 that have the problem. I have a suburbanite on my wrangler with the identical problem. I will be watching this thread for an answer.

    On a side note: mine didnt have this problem untill i got it back from warranty issues as usual.
     
  7. blueline38

    blueline38 Senior Member
    Messages: 436

    There has been no update on this thread so I will give you mine. My plow started acting slow but would speed up after moving the blade. Sometimes I would have to turn off the controller and turn it back on again. Well, last night I got to work and lowered the plow. This morning the plow slowly rose and that was it. It would do nothing else and I did not attempt to put it down for obvious reasons. I stopped at a dealer on the way home and he originally thought that the plow was fozen. He pulled it in and returned to tell me that the motor is shot. The plow is three years old, at least this is the third season, is it normal for a motor to go? Not a huge deal but the part is around $200.00. Anyway, that's my update!