1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Cable System, Ram wont lower

Discussion in 'Western Plows Discussion' started by SWOHSnow, Jan 6, 2010.

  1. SWOHSnow

    SWOHSnow Junior Member
    Messages: 10

    Hi all,

    I have an old cable style western plow mount. I believe it is called the Isarmatic. Anyways, the plow angles left and right just fine. Plow raises just fine. And up until yesterday, it went down just fine. However, I now cannot get the ram to lower. I can see the cable moving, when we move the stick, from up to down, and even hear the pump engage when in the up position, but nothing doing for down. Any ideas what we might be up against? Quick fix possibly?

    Thanks in advance.
     
  2. Evanbrendel

    Evanbrendel Senior Member
    Messages: 181

    try and take the cover off where the cable enters the pump and work the lever inside with a screwdriver.
     
  3. SWOHSnow

    SWOHSnow Junior Member
    Messages: 10

    I did already try that, which is how I know the cables are working themselves. I used a screwdriver to work the lever, no luck.
     
  4. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Last edited: Jan 6, 2010
  5. SWOHSnow

    SWOHSnow Junior Member
    Messages: 10

    Thanks for all the help. Turned out to be the cables were stretched and the controller was bad. Replaced and all is working now.
     
  6. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    good luck........