1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

cable pump

Discussion in 'Western Plows Discussion' started by wahlturfcare, Dec 12, 2007.

  1. wahlturfcare

    wahlturfcare Senior Member
    Messages: 320

    I have a isermatic 3 pump with new cables that me or the dealer cant get to go up/down or left/right quickly. we could only get it to turn while the blade is down and evrything is somewhat slow.

    Is there something I should try?
     
  2. mohawkmike82

    mohawkmike82 Junior Member
    Messages: 19

    Im having similar issues with my cable op pump. I just got it. Put new cables on, and adjusted them according to the service manual. Blade will raise and lower pretty well but will only angle slowly while on the ground. The manual is saying to adjust the lift valve out a little bit which seems simple enough but mine is locked up frozen solid. Please let me know if you solve your problem. Ill post here if I figure mine out. Good luck buddy!
     
  3. wahlturfcare

    wahlturfcare Senior Member
    Messages: 320

    i was told by the dealer that if i adjusted the lift valve that it might slow the lift/lower speed down and increase the turn. They also said to drain the fluid and check the filter inside to see if it is plugged up.
     
  4. packey

    packey Member
    Messages: 97

    pull the motor off and check the pump filter. I have found out that these old mark III's have a filter on the pump and if the pump has been setting up a while the sludge in the bottom of the resivoir will clog up the filter. I just put a truck back into commercial service after setting 5 years nothing was broke or torn up they just parked the truck in a pasture and left it. They got tired of the old school power wagon with manual steering and a 4spd. i have spent time on this truck getting it back in operation and I can say after 40 hours of use this season everything is running better now than when I started. Hoever I am still working out the old girls bugs.