1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Cable control issues

Discussion in 'Western Plows Discussion' started by RMHSR, Mar 19, 2006.

  1. RMHSR

    RMHSR Member
    Messages: 49

    I purchased a used older cable operated plow. The story I received is that it worked fine when removed 2 years ago. Sat since then. I have everything hooked up and cannot get the cables dialed in. If I remove the cable and run the control on the pump by hand everything works great. When I install the up/down cable, if I push the cable down then the controller will lift but not drop. If I pull the cable up, it will lower but not raise. I can't get it to go left/right at all. Motor runs on all appropriate functions. It seems that the cables aren't moving enough. I replaced the up/down cable. Any advise? Thanks.
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,990

    something my be worn out in the control box it's self. The base or platen would be my guess.
    The other issue could be a out of adjustment lift valve.
    Go to the western site to down load trouble shooting information
  3. NJ Plowman

    NJ Plowman Senior Member
    Messages: 799

    Bring it to a Western dealer and have him set it up for you. It will probably last you the next ten years. I run 12 Cable Operated Western Pro Plows that we originally bought in the late 70's and early 80's every day!