1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Buyers TGSO1B Spreader

Discussion in 'SnowDogg Snow Plows' started by MOUNTAIN MOVER, Feb 6, 2008.

  1. MOUNTAIN MOVER

    MOUNTAIN MOVER Junior Member
    Messages: 21

    Keeps clogging no matter what I do.

    Can I adjust the auger?

    Cannot run more than 150 lbs of rock at a time, should handle 600.

    HELP
     
  2. smoorman

    smoorman Sponsor
    Messages: 446

    When did you buy it? Is this something that just started happening, or an issue with it since it was new?

    Let me know and I can help you out.

    Thanks
    Scott Moorman
    BPC Director of Engineering
     
  3. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    spreader

    sound's like the motor is a little weak,might want to retrofit the salt dog electric vibrator .
     
  4. MOUNTAIN MOVER

    MOUNTAIN MOVER Junior Member
    Messages: 21

    Bought it last fall, has been this way since new, I think a set screw or pin is missing from factory.....is the auger supposed to sit down on the paddle? I dont think so but then again I've never owned a buyers b4. The parts diagram doesn't give a clear explanatiion.
     
  5. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    spreader

    make sure the set screw and the woodruff key is there and tight some time's they push the key out installing the auger ,and tighten the set screw against the slot for the key then it loosen's ! i cant remember it either bottoms out or to were the set screw is in the center of the key ,one way or another will kick the key out .
     
  6. MahonLawnCare

    MahonLawnCare Senior Member
    from Ohio
    Messages: 852

    your motor is junk
     
  7. plow tech

    plow tech Member
    Messages: 32

    Did you get it fixed yet?
     
    Last edited: Jan 6, 2009
  8. snowman34

    snowman34 Junior Member
    Messages: 7

    this is the same problam i have also.willin to bye the viebrator.but lookin to fix the problam.a little less money.it was brand new,last year.an has did it each trip almost.i was telling other guys about the buyers salters.so my wife work.could create sells .but 2 friends had problams also.so now i just say it came with my truck.
     
  9. ChiTahoe

    ChiTahoe Senior Member
    Messages: 143

    If you're still having an issue it should be under warranty. There are issues with the controllers being too sensitive and throwing codes, now does it "clog" and the motor does not work or does the controller flash and display a code and then the motor does not work?
     
  10. snowman34

    snowman34 Junior Member
    Messages: 7

    my problam is it clogs.throws codes forget which code.i was giving a new controller.still clogs,must of the time.last year an this year.i bought it dec 2011.
     
  11. ChiTahoe

    ChiTahoe Senior Member
    Messages: 143

    Buyers has an updated controller for these issues. The updated unit has a green tag on the bottom of it. I'm waiting to get one tommo. Once I do, I'll confirm.