1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

buyers salt spreader

Discussion in 'Commercial Snow Removal' started by jwwieberg, Feb 8, 2004.

  1. jwwieberg

    jwwieberg Junior Member
    Messages: 18

    I bought a buyers suv salt spreader and the darn thing just don't just put out very much salt. I try benting the spinner more but that didn't help. You can see the salt floating around when it's running, shut it off and the salt pours out.
  2. gt_racer50

    gt_racer50 Senior Member
    from Ohio
    Messages: 484

    Was it the $600 SUV Pro or the $300 Suv model?
  3. snowmike

    snowmike Junior Member
    Messages: 7

    Might be a stupid question but did you put the moter wires on the right way. Try reversing the leads on the motor. maybe the motor was running in reverse.
  4. Bolts Indus.

    Bolts Indus. PlowSite.com Addict
    Messages: 1,176

    sounds like it might be running backwards.
  5. jwwieberg

    jwwieberg Junior Member
    Messages: 18

    It's the cheaper $400.00 model. The wires were already hook up, it spins clock wise which looks like the way it's suppose to. I saw on a search other people had change to a different auger style. I bought mine from Northern Tool, where could a person find the mini style auger. Do they have dealers to order from?
  6. steve in Pa.

    steve in Pa. Member
    from Pa.
    Messages: 86

    your spinner should be spinning counter clockwise, at least thats how mine spins.:drinkup:
  7. snowmike

    snowmike Junior Member
    Messages: 7

    So, does mine.:drinkup:
  8. gr84

    gr84 Junior Member
    Messages: 7


    are was backward to we had to switch the wires on our 600 lb model. that don't mean anything that the wires were hooked up mistakes can happen and if it has the rheostat make sure the wires are hooked up right there as well we burnt ours out because it was hooked up wrong just some words of advice