1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Buyers please help, i have some issues.

Discussion in 'SnowDogg Snow Plows' started by ZachXSmith, Feb 27, 2011.

  1. ZachXSmith

    ZachXSmith Senior Member
    Messages: 145

    I bought three snow dogg plows this season, and one last season. I am having problems with 2 of them, on the ex90 on my 2003 3500 silverado the headlights harness never worked. The dealer says it is the correct one but we cannot get it to work. The plastic snow deflector broke and so did the plastic pump cover. On the Md75 the plow will just randomly stop working and I will have to hit snow piles with it and then it will just snap out of it. Last time out it never did, I short chained it to get her home, and is still not working. The lift cylinder is bleeding green, from I think the seal. The deflector, and pump cover are also broke on that one as well. Also the controller blinks red randomly and the turn signal bulbs are broke from coming out and rattling around in the headlights housing on both of these plows.
    Please call me at 989-213-3688. I need the Md75 up and running ASAP.
    Thanks
    Zach Smith
     
    Last edited: Feb 27, 2011
  2. Matson Snow

    Matson Snow PlowSite.com Addict
    Messages: 1,985





    Zach...


    What did the Dealer say....Or is he just telling you your SOL....Maybe you should just contact Buyers direct...I think someone that purchases 3 Plows deserves some sort of customer service...I could be wrong....Good Luck with this issue....I hope it works out
     
  3. npi9181

    npi9181 Member
    Messages: 32

    check the headlight harness it should be a 16071150 headlight adapter I would get it to the dealer to check it over should be all under warranty
     
  4. GabrielFarms

    GabrielFarms Junior Member
    Messages: 14

    If your headlight adapter is like the adapter on our 07 chevy, it can be hooked up wrong. We were intalling ours last fall and got it all back together just to find out the head lights didnt work. Took the headlights back out and swapped the connectors around and it worked great. The rest of the issues should be covered under warranty. I heard that they are replacing the hard plastic deflector with a rubber one. I hope you get everything taken care of.
     
  5. RedArrow

    RedArrow Member
    Messages: 50

    I had a similiar issue last friday...right in the middle of plowing, no angle no up, just down (once). Short chained it and ran it into my distributor. He had great things to say about Snow Dogg, only issue were the lift cylinder packing which everyone knows about and some issue with the V plow they just came out with. Troubleshooting didnt show much other than no power out of the solenoid. We did have a couple of times where it was intermittant like your talking about hitting the snow pile. We finally put a meter on the control pole of the solenoid and tried to move the plow, ti was very faint, not a full 12 volts. We finally ran a direct wire to the solenoid start pole with a clean 12 volts, it fired right up. Must have been a bad wire in the harness. Not certain because he just ran a clean new wire to the controller from the battery. Good luck!
     
    Last edited: Mar 18, 2011
  6. ZachXSmith

    ZachXSmith Senior Member
    Messages: 145

    I broke a passenger side headlight off right at the base on the last snow event. I was suppose to receive a replacement but it looks like I've gotten all the support buyers is willing to give me on a 3 month old plow. Took them over a month to ship my last parts and my Md75 is still not working.... looking like I'm gonna have to figure this one out by my self.
    Thanks so much buyers :( (sarcasm)