1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Bronco won't start

Discussion in 'Ford Trucks' started by Jgramlich, Dec 18, 2010.

  1. Jgramlich

    Jgramlich Senior Member
    Messages: 111

    (Unsure if this is relevant) Today I replaced the windshield wiper motor. I had to splice the ground. I removed the battery from the truck. Plugged everything back in - wipers worked, truck had power. I went to start it and it wouldn't even turn over or click - no sound at all. No change when I tried to jump it.

    Battery terminals are clean and tight. Battery and alternator are like new. Truck has had a power draw for the past few weeks. I just feel like this has to be related to the work I did today.

    Could I have blown the starter? Maybe the solenoid? Bad relay? Fuse?

    As if I haven't had enough issues in the last month... I feel like a regular in this forum.

    As always, thanks a ton.
  2. icemountainwv

    icemountainwv Junior Member
    Messages: 4

    you didn't knock the small solenoid wire off while you were working under there did you?
    might try taking off the solenoid and give it and the fender a good cleaning make sure it's getting ground.
    have you tried jumping the solenoid with a screwdriver? small screw to the batt. side,it should turn the engine but not start unless the key is on.