1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Bronco w/ 5.8l running rough

Discussion in 'Ford Trucks' started by captbo, Feb 4, 2010.

  1. captbo

    captbo Senior Member
    Messages: 112

    I am picking up a 1995 that the current owners says runs rough he has replaced the cap/ wires/ plugs and although it ran a little better still runs rough, I am picking this up Friday and am wondering how is the best way to trouble shoot this, I know when the EEC gets wet this can happen but we both feel that is not the case, please help!
     
  2. mrv8outboard

    mrv8outboard Senior Member
    Messages: 197

    EGR sticking, TFI module, Vacuum leak. Put a scan tool on it and get the codes. You can always run a whole can of Seafoam through the intake using a vacuum port at the vacuum tree on the top of the upper plenum.
     
  3. captbo

    captbo Senior Member
    Messages: 112

    Thanks I can't wait to get into it !
     
  4. DJ Contracting

    DJ Contracting PlowSite.com Addict
    Messages: 1,392

    If I'm not mistaking there are two plug wires that can be crossed and the truck will run however it will run rough, I believe it is 5 and 7. Do a google on that I'm sure you'll find it on there.
     
  5. RIVERVIEW7

    RIVERVIEW7 Member
    Messages: 53

    check the firing order it will run on the 5.0 firing order
     
  6. RacingZR

    RacingZR Senior Member
    from Maine
    Messages: 398

    Check firing order first then the timing if still running rough.
     
  7. captbo

    captbo Senior Member
    Messages: 112

    Thank all great advice, it would be great to find the FO is crossed up!
     
  8. linckeil

    linckeil PlowSite.com Addict
    from CT
    Messages: 1,265

  9. captbo

    captbo Senior Member
    Messages: 112

    very good info! thanks again!, I went today and bought it starts easy enough sounds ok , but you can see the motor has a mild shake, it rev'ed ok and did not diesal when it was turned off! it but could not get it home as the tools at Uhaul would not let me have the trailer sayingit would not carry the bronco,,, HuH this is aftyer they confirmed it on line and on the phone with a human! what tools I was trying to get this done before our "epic" snow storm happens but I had to leave it and go afterit after the storm!
     
  10. jb1390

    jb1390 Senior Member
    Messages: 710

    If you have insurance you could just drive it.....many states will let you do that for a few days after you complete the sale as long as you have insurance, that is really what they care about.
     
  11. trustno1

    trustno1 Junior Member
    Messages: 22

    I just followed the link above and took a quick look at all the bulletins on broncos. Most of the stuff wrong with my '95 is covered.

    Scotty