1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Brake problem involving Chevys and Boss salt spreaders

Discussion in 'Boss Plows Discussion' started by deranged311, Dec 23, 2010.

  1. deranged311

    deranged311 Junior Member
    Messages: 2

    I sell and install truck accessories for a living. This includes snow plows and salt spreaders.
    We have a 2003 Duramax here and we just wired a salt spreader to and now both brake lights are on and it says 'service brake system' on the dash.

    This is the second time this has happened to us. The first time the customer took his truck to the dealership to have it serviced and all they told him was that 'a wire was loose.'

    The salt spreader is wired
    1. to the positive
    2. to an ignition source
    3. a ground
    4. has it's own relay mounted under the hood

    The harness for the spreader is ran all the way down the frame to the hitch where the salt spreader is located.

    Has anyone ever heard of Chevy's having brake problems after certain applications being wired in?
  2. deranged311

    deranged311 Junior Member
    Messages: 2

    Problem solved.

    The wiring harness when wired too closely to the master cylinder will trip a sensor in the master cylinder that sets off the brake lights.
  3. ihdriver7088

    ihdriver7088 Senior Member
    Messages: 315

    imho i would have hooked it up to the trailer plug