1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

brake light problem

Discussion in 'Chevy Trucks' started by waveconcepts, Nov 30, 2008.

  1. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    I've got a 1990 Chevy 1500 i have brake lights when ever i push the pedal but when i flip the lights on no running lights. The brake lights work when pushing the pedal still ,now when i first got the truck it had one working head light, broken ground wire fixed it. then i put in aftermarket stereo running lights quit working for several days (also was not driving it) during that time worked on them for a couple hours still nothing then one day went out to check them and they were working i figured leave well enough alone. Now all the bulbs are brand new then about a month later now i'm back to same problem. i checked to see if the terminals by chance had corrosion but nothing. is there a place in the truck i could check and see if it is infact sending power back, if so then def. break in the wire some where.
     
  2. bharry20

    bharry20 Senior Member
    Messages: 124

    is it just in the rear that the problem occurs, or the entire truck dosen't have running lights? did the lights work prior the the radio install? and when you installed the radio did you get the proper adapters or did you cut the factory plug off and directly wire the radio in?
     
  3. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    I bought the wiring harness can't stand when people cut wires it makes it more difficult, it worked befor the install. I ended up taking out the aftermarket just to make sure as well also when i turn on the lights the head lights work just fine with no prob so do the front running lights but just no running rear lights.
     
  4. RichG53

    RichG53 PlowSite.com Addict
    Messages: 1,135

    When you say running lights do you mean parking lights . ???? Or do you mean Day Time Running lights.. ????? Because they did not have them back then.... I won a 92 no DRL's
     
  5. RichG53

    RichG53 PlowSite.com Addict
    Messages: 1,135

    If you look under the hood just below the brake canister you will see a cluster of wires going into the fire wall one of the looms goes down it runs along the frame to the back of the trk ... Unclip that plug and see if there is any correction in the plug connections...Or follow it back to were it branches off to tail & brake & back up lights check those connections also... Good Luck ! ! ! !
     
  6. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    it looks like some one put a new bed on it at one point but in the rear there are the 3 lights per side turn signal brake light(when pushing pedal) and the running brake light (for night time) i guess those would be parking then makes since lol. i'll check the line under brake booster now post back in about 30 to 45 minutes hope that helps describe if not let me know and i'll try to better explain thanks everyone for your help
     
  7. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    Dose that truck have a trailer plug?

    Is So what type of plug and is it hardwired in to the harness or pluged in to the truck side?
     
  8. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    yes it does actually it had 2 different hook ups for different trailer plugs took one off and cleaned the other one up just incase of cor..
     
  9. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    sorry it is the 4 wire straight across not the round type cant think of the name off the top of my head plugged
     
  10. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    Stright 4 plug

    I bet it just hangs there dosen it?

    Is it just hard wire in to the truck side?
     
  11. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    yep just got under there in the back of the truck to check the 3 way splitter the guy had left on there and there is power going back there. from the three way splitter back to to tail lights i'm losing power so i'm going to rewire it and see if that doesn't fix the prob. if that makes since i'll repost results in about an hour. once again thanks for all everyones help ( he atleast had the splitter zip tied to the frame)
     
  12. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    Cut that Damn Plug out of there and leave it out till spring.

    Them plugs get salt and snow up in them, and will eat your whole wire harrness up.

    I burn up a headlight swich in a 90 GMC cause of that once
     
  13. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    ok i tried messing with it for the last hour i'm gonna just cut it off i'll let you know in 30 minutes man i really appreciate the help..
     
  14. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    LOL no problem,

    I been ther and have had this problem too
     
  15. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    ok cut it off and took it out but still same thing i'm going to trace it to cab its almost like i've got a dead short but i'm having trouble locating the wire in the cab. i dont know if there is a relay some where i took the light switch out and checked it and it seems to be fine. any other sugg?
     
  16. bharry20

    bharry20 Senior Member
    Messages: 124

    if you have power at the rear of the truck then the problem is in the tail lights or the light harness. if you have doubt about the power running back then gat a big jumper wire and hook it to the positive battery side and the touch it to the running lights wire at the box. do it with the lights wire not hooked to the truck harness. if they work then the problem is in the truck if not then the problem is in the lights from that point back.
     
  17. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    barry did just what you said to try and the brakes work that way so that would mean it's in the truck what should be my next move?
     
  18. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    bharry20 sorry
     
  19. bharry20

    bharry20 Senior Member
    Messages: 124

    i am a little confused. what wire did you touch? if you touched the wire for the tail lights and the brake lights came on then your problem would be at the rear.
     
  20. waveconcepts

    waveconcepts Junior Member
    from indiana
    Messages: 23

    i touched the brown wire which is the rear tail lights the brake lights work just fine day or night i guess i should have refered to them as tail lights in the begining but the brown wire is the power for the rear tail lights and they both fired up like there supposed too but i can't get them to come on when i flip the lights on. does that help any? if not let me know and i'll try wording it differently thanks again