1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

??? bout my 08 f250

Discussion in 'Ford Trucks' started by iceyman, Feb 4, 2008.

  1. iceyman

    iceyman 2000 Club Member
    Messages: 2,547

    on the dash where the mileage is sometimes when i start my car for the first time in the morning i got to back out and the truck is real sluggish and a wrench comes up in the display. since i have the 5 spd i can shut my truck off then turn it back on after pullin out of my drive but if i dont turn it off the truck wont really shift gears and will get no power. idk only happens once in a while but just dont know why it does it. any help is appreciated as i dont want to look in the book. thanks
     
  2. KGRlandscapeing

    KGRlandscapeing 2000 Club Member
    Messages: 2,660

    dose it have the 5.4in it? cause they normaly run like crap until they get warm. kinda sound like a garbage truck or a school bus. i guess its kinda normal because mine and my dads truck dose it. no light normaly thou. now if its a powerstroke then its a diffrent story
     
  3. MarksLand

    MarksLand Junior Member
    Messages: 22

    I have a 2008 F-350 and my "wrench light" came on. I would reccomend bringing it into your dealer so they can run the codes. Mine turned out to be a pretty major repair, being a new truck it will be covered under warranty. Good luck!!
     
  4. snowman2025

    snowman2025 Senior Member
    Messages: 152

    if its a Diesel with an automatic the computer won't hardly let the truck run until the water is around 140, atleast thats how it is on my 6.0. I have a standard transmission so its not like it doesn't let me shift gears, but my engine is really sluggish.

    It helps to keep you from blowing it up with a hot engine really quick and really cold water going through it.

    I can't tell if your vents are red or black from the pic, so i can't tell if you have a gas or diesel.

    just my .02c
     
  5. iceyman

    iceyman 2000 Club Member
    Messages: 2,547

    thanks for the responses. i got the baby engine, no diesel, and stick. when i turn it off and turn back on it goes away and runs slow for bout half a mile.
     
  6. Gicon

    Gicon Senior Member
    from MA
    Messages: 989

    The answer to your questions is......because its a Ford....
     
  7. JeepPlow18

    JeepPlow18 Senior Member
    Messages: 658

    That is ridiculous. Its brand new...fords. Im glad I have my chevy:D
     
  8. 08F3506.4L

    08F3506.4L Member
    Messages: 30

    On my 08 diesel a differnt light came on.. It says something about a problem with trailer wiring. But it never has a trailer behind it?? Who knows bring it in! thats why we buy new
     
  9. iceyman

    iceyman 2000 Club Member
    Messages: 2,547

    yea good call:drinkup:ussmileyflag
     
  10. Easy

    Easy Senior Member
    Messages: 325

    Watch out for the problem with trailer wiring. The back side of my trailer plug got salt water in it and it killed my battery. While recharging the battery, the connection started smoking. I had to cut the wiring off and replace the plug. Seems there was no di-electric grease in the connector from the factory.
    I had no fire, but the possibility was there.
    Don
     
  11. iceyman

    iceyman 2000 Club Member
    Messages: 2,547

    ill def check it today thanks....:drinkup::waving: