1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

both plow lights and one truck light activate

Discussion in 'Western Plows Discussion' started by Gear_Head, Jan 12, 2012.

  1. Gear_Head

    Gear_Head Senior Member
    from IL
    Messages: 245

    The problem started last winter and I never really tracked it down. The truck's passenger side headlight stays on when the 2 plug uni-mount system is hooked up. All lights on the plow work correctly and are activated. I am assuming it is a relay, just trying to wrap my head around how I could have both truck and plow lights at the same time.
     
  2. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    You say the lights did work correctly at one time and then last year they began to fail right? So they must have been hooked up right in the first place. Perhaps one of your relays is hooped and shorting out the contacts inside causing power to go to both outputs simultainiously or perhaps yous have failing insulation somewhere causing a short? I would try buying one new relay and then systematically sub it in one space at a time. If you switch the relay out and there is no change you know the removed relay is good so swap it into the next slot until either you have swapped all the relays or resolved the problem. Here is a link to the Western schematics manual. It includes the relay system, have a look and see if you can find your system. http://library.westernplows.com/ddcommon/dd_pdf/pdfs/22373.07_110108_for_web.pdf
     
  3. Gear_Head

    Gear_Head Senior Member
    from IL
    Messages: 245

    this is the direction I thought I would have to go, just wanted a second opinion. I appreciate it.