1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss would not work this morning

Discussion in 'Boss Plows Discussion' started by mike33, Feb 27, 2006.

  1. mike33

    mike33 Senior Member
    Messages: 335

    Had a light snow tis morning and went to put plow on and tower would not power back .Called my dealer and told me to check connecters, i took a torch cleaning brush to clean female plug on truck and put some dio- grease on and it worked than. Ive had this boss for a year with no problems. Had all kinds of problems with meyer and i never thought to maintain this plug . My main quetion was if i couldnt get it to work how could i take it to dealer. He told me in that case switch down in float and jack it up and turn switch off so i would not lower it down by mistake. Has anyone ever had to do this when there plow wouldnt power up?

    mike
     
  2. Emerscape

    Emerscape Member
    Messages: 58

    Yes..I had the exact problem. Drove me nuts becuase it started to act up also once it was on the truck. I would press down and it would go up etc. After cleaning all the connections the only problem i had was that it wouldnt power up. The dealer replaced my toggle switch saying it was recalled and a new version had come out. Check with your dealer they should know what im talking about.

    just read your post again. what you can do is take the pin out of the top of the piston that attaches to the headgear. drive the truck up to it.. then manually push up the headgear. its real easy becuase it isnt attached to the lift piston. Then have someone (or u can do it urself.) press down on the control so that the piston extends. It take a minute or two to finagle it but u can get it back up to the headgear and put the pin back in. if you extend it too much then put it in float and push it back down. just be careful with your hands and the hoses
     
    Last edited: Feb 27, 2006
  3. mike33

    mike33 Senior Member
    Messages: 335

    Bobcatservice

    thanks, i went to my dealer with out plow to check out truck,etc. he gave me a switch on the tower just in case said they had some problems with them. Cleaned the plug came home and plow worked. The last snow we plowed my left wing woild not move, called dealer and said first thing check the plug. I then remembered i just previous hit a man hole ( new lot ) this might of jarrred it loose. I wigggled it and it worked fine plowed for 8 hours no problem until this morning. I guess i got lazy with this boss i should of known better, used to have problems with meyer and could fix them.

    mike
     
  4. GA73

    GA73 Member
    Messages: 90

    for some reason ive had alot of trouble with corrosion on the boss plugs. have yet to find good cleaner or corrosion prohibitor.
    with the problem of the tower not going up is usually a ground trouble. clean negative cable and spread the plug alittle
     
  5. mike33

    mike33 Senior Member
    Messages: 335

    Bobcatservice

    What really got me yesterday morning saltspreader quit during salting, same problem with the plug. I got home and sprayed it with an electric cleaner and applied dio-electric grease.
    mike
     
  6. 06HD BOSS

    06HD BOSS 2000 Club Member
    Messages: 2,611

    Everytime i connect the plugs i always wrap duct tape around the connection to prevent any water or condensation from seeping in. Always works out fine...knock on wood.
     
  7. mike33

    mike33 Senior Member
    Messages: 335

    Bobcatservice

    Thanks! i thought about doing that, wondering if anyone ever tried. I will do that next time. I also thought about running a second wiring harness for a backup. I have an older truck with a meyer that i purchased with a plow already on it. It had the old flip switchs and i decided to put a joy stick on the gear shift. I thought why should i disconnect the first one i could have a back up. Now it has 2 different switchs.

    mike
     
  8. TLS

    TLS PlowSite.com Addict
    Messages: 1,425

    You do have the controller on, and it is in FLOAT mode (RED), right?
     
  9. mike33

    mike33 Senior Member
    Messages: 335

    bobcatservice

    sure did, but the problem in the connector
    mike