1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss wiring nightmare!!!

Discussion in 'Boss Plows Discussion' started by cameo89, Jan 27, 2008.

  1. cameo89

    cameo89 Senior Member
    Messages: 669

    I just hooked up my boss rt3 on my dodge and the smart hitch 2 switch worked a few times (moter runs), the plow will only go up ,if you angle blade it sometimes works and will sometimes it lets the blade down, but blade will not drop w/ the down button.
    moter runs when you use all buttons on control box, but does not move plow

    The boss head light switch does not work wright,when switched to plow mode, plow lights do not work unless you use the control box and put plow down, then the plow lights work, but soon as you go to raise the plow the lights shut off and go to the truck lights

    Could this be a bad ground or a bad silonoid?

    This is grounded to the battery, but the siloniod is not!

    plow is raised all the way up and i can't get it down, moter runs but plow does nothing.
    need help please:dizzy:

    Thanks in advance for any and all help, Yon
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You have a ground issue somewhere....check/clean every ground in the harness..bumper plug power connector, ground cable on the battery, the ground harness on the coils that tie all the coils together and then go to either the light tower or the motor (depending on year).

    Check the small gage brown ground wire that should be connected to the neg battery terminal especially, because this is the wire that feeds ground to the under hood relays that control the plow lights.
  3. cameo89

    cameo89 Senior Member
    Messages: 669

    I had small brown wire going to Pos + (opps) cleaned all grounds and replace solenoid and she works like new, thanks B&B

  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    That'll do it every time. Sounds like you recently had the battery disconnected?

    And your welcome..too bad they aren't all that easy to fix :).