1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss V is taking out my Highbeams on my trucks!

Discussion in 'Boss Plows Discussion' started by brickslayer, Feb 1, 2014.

  1. brickslayer

    brickslayer Member
    Messages: 70

    Any help would be appreciated. Second truck that I noticed when (I have the plow off) and need to switch over to high beams the headlights all go out. Think my older boss V is the reason. First thing I would like to address are the trucks and get the high beams functioning and secondly address why that plow would be taking out the high beams. First truck was a 99 dodge diesel second was 01. Thanks in advance to anybody with some imput!

    Plow in question is Rt3 pre smarthitch2. Was 11pin Converted over to 13pin. by the traditional conversion kit. Ruling out that conversion being the problem because I noticed 1st truck high beams out previous year before the conversion. Now this year that plow is on my 01 and sure **** driving that truck today with the plow off and went to use highs and lights out. Haven't dug into anything yet open for suggestions. Thanks again!
     
  2. djagusch

    djagusch 2000 Club Member
    from mn
    Messages: 2,071

    Try replacing the relay first. Most likely the issue. Now why the old plow would make it go bad? I would verify the old plow fried the relay by seeing if it fried the new one, before checking wiring shorts and grounds.
     
  3. brickslayer

    brickslayer Member
    Messages: 70

    Checked fuses. Replaced relay. And still nothing. Clueless on this one.
     
  4. peanut2008

    peanut2008 Junior Member
    from se mich
    Messages: 2

    headlight switch. my boss plow eats the switches in my 98 dodge
     
  5. brickslayer

    brickslayer Member
    Messages: 70

    Have low beams. Just not highs. Indicator on dash shows brights should be on. So still think it's the switch? And are you saying the on off switch or turning signal/brights lever is what goes out on yours?
     
  6. brickslayer

    brickslayer Member
    Messages: 70

    Also if it helps, the brights indicator on the dash is always on with the plow attached. Same with both trucks. Not sure if that occurred after the high beams went out or right from the start.
     
  7. peanut2008

    peanut2008 Junior Member
    from se mich
    Messages: 2

    headlight switch in dash, replaced my dimmer switch in column first that wasn't it had dims no brights