1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss smart hitch 2 - loose headgear

Discussion in 'Boss Plows Discussion' started by RepoMan207, Jan 17, 2015.

  1. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,038

    Going to help a buddy with a boss straight 9' with smart hitch 2. He states headgear is loose, mounts fine, but the tower slumps forward once connected. He put a bungy cord on it to hold it up.

    Without looking at it, I suspect worn pin, but curious if anyone else has had this issue, and it's a common problem/easy fix.?.?
     
  2. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    take pixs first for us
     
  3. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,038

    Will do tomorrow
     
  4. secret_weapon

    secret_weapon Senior Member
    Messages: 437

    Loose bolts on truck mount? Mine came loose a couple years ago. Could see the lights(headgear) move back and forth while plowing. Gotta check all the bolts, make sure they are tight every so often.
     
  5. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,038

    The only thing I could find that looked out of sorts was some mounting pins that had been flattened out on one side. They appear to be welded in...has anyone had this issue before?

    Unfortunately my phone died just as I was getting around to inspecting it, so I couldn't take pictures, however, I found a shot of the headgear on google that I could point them out in.


    Picture3.jpg

    Picture3.jpg
     
  6. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    Did you hook it back up and look again. After I hook mine up I feel the pins to make sure they went all the way through.
     
  7. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,038

    Yeah, I disconnected it earlier in the day, towed it to get new tread, and hooked it back up upon my return and inspection. He's holding it up with bungees...which really isn't doing any good once the plow is lifted, the headgear tilts forward a good 3-4"
     
  8. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    Check the truck side support .Sounds like one is broken.
     
  9. scottydosnntkno

    scottydosnntkno Member
    Messages: 87

    If those pins are flattened, that's your problem. It's like putting a 1/2" bolt on a 1" hole, of course it's going to have movement.